summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/hpack/hpack-2.3.0.ebuild')
-rw-r--r--dev-python/hpack/hpack-2.3.0.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/hpack/hpack-2.3.0.ebuild b/dev-python/hpack/hpack-2.3.0.ebuild
new file mode 100644
index 000000000000..7bd359160a6d
--- /dev/null
+++ b/dev-python/hpack/hpack-2.3.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy)
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python HPACK header compression"
+HOMEPAGE="http://python-hyper.org/hpack https://pypi.python.org/pypi/hpack"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? (
+ >=dev-python/pytest-2.9.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-cov-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-1.14.0[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-3.4.2[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ # Remove a test that is not part of the mainstream tests
+ # Also, it's data directory is not included in the release
+ rm test/test_hpack_integration.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all(){
+ use doc && emake -C docs html
+}
+
+python_test() {
+ PYTHONPATH="${S}/test:${BUILD_DIR}/lib" \
+ py.test -v hpack test/|| die
+ cd test
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}