summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/hpack/hpack-3.0.0.ebuild')
-rw-r--r--dev-python/hpack/hpack-3.0.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/hpack/hpack-3.0.0.ebuild b/dev-python/hpack/hpack-3.0.0.ebuild
new file mode 100644
index 000000000000..67d5b0266c6a
--- /dev/null
+++ b/dev-python/hpack/hpack-3.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy)
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python HPACK header compression"
+HOMEPAGE="https://python-hyper.org/hpack/en/latest/ https://pypi.python.org/pypi/hpack"
+SRC_URI="https://github.com/python-hyper/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/pytest-2.9.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-cov-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-1.14.0[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-3.4.2[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ # Remove a test that is not part of the mainstream tests
+ # Also, it's data directory is not included in the release
+ rm test/test_hpack_integration.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ PYTHONPATH="${S}/test:${BUILD_DIR}/lib" \
+ py.test -v hpack test/|| die
+ cd test
+}