summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/html5-parser/html5-parser-0.4.10.ebuild')
-rw-r--r--dev-python/html5-parser/html5-parser-0.4.10.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/html5-parser/html5-parser-0.4.10.ebuild b/dev-python/html5-parser/html5-parser-0.4.10.ebuild
deleted file mode 100644
index f0bb97ed5d38..000000000000
--- a/dev-python/html5-parser/html5-parser-0.4.10.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1 toolchain-funcs
-
-DESCRIPTION="Fast C based HTML 5 parsing for python"
-HOMEPAGE="https://github.com/kovidgoyal/html5-parser/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm x86"
-IUSE=""
-
-BDEPEND="
- virtual/pkgconfig
-"
-DEPEND="dev-libs/libxml2:="
-RDEPEND="${DEPEND}
- dev-python/chardet[${PYTHON_USEDEP}]
- >=dev-python/lxml-3.8.0[${PYTHON_USEDEP}]"
-
-distutils_enable_tests setup.py
-
-src_prepare() {
- # Soup is not used when lxml is available.
- rm test/soup.py || die
- sed -i -e 's:-O3::' setup.py build.py || die
- distutils-r1_src_prepare
-}
-
-src_configure() {
- export PKGCONFIG_EXE=$(tc-getPKG_CONFIG)
-}