summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/httpauth/httpauth-0.3-r1.ebuild')
-rw-r--r--dev-python/httpauth/httpauth-0.3-r1.ebuild22
1 files changed, 16 insertions, 6 deletions
diff --git a/dev-python/httpauth/httpauth-0.3-r1.ebuild b/dev-python/httpauth/httpauth-0.3-r1.ebuild
index 703fdd988ecb..c1f53e87effa 100644
--- a/dev-python/httpauth/httpauth-0.3-r1.ebuild
+++ b/dev-python/httpauth/httpauth-0.3-r1.ebuild
@@ -1,19 +1,29 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
-inherit distutils-r1
+inherit distutils-r1 pypi
DESCRIPTION="A WSGI middleware that secures routes using HTTP Digest Authentication"
-HOMEPAGE="https://github.com/jonashaag/httpauth/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="
+ https://github.com/jonashaag/httpauth/
+ https://pypi.org/project/httpauth/
+"
LICENSE="ISC"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-distutils_enable_tests nose
+PATCHES=(
+ "${FILESDIR}/${P}-remove-nose-dependency.patch"
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest tests.py
+}