summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/inotifyx/inotifyx-0.2.0-r1.ebuild')
-rw-r--r--dev-python/inotifyx/inotifyx-0.2.0-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/inotifyx/inotifyx-0.2.0-r1.ebuild b/dev-python/inotifyx/inotifyx-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..e57c28f4453e
--- /dev/null
+++ b/dev-python/inotifyx/inotifyx-0.2.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings to the Linux inotify file system event monitoring API"
+HOMEPAGE="http://www.alittletooquiet.net/software/inotifyx/"
+SRC_URI="http://launchpad.net/inotifyx/dev/v${PV}/+download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND=""
+RDEPEND=""
+
+python_prepare_all() {
+ use test && DISTUTILS_NO_PARALLEL_BUILD=1
+}
+
+python_test() {
+ "${PYTHON}" setup.py build -b "build-${EPYTHON}" test || die "Tests failed under ${EPYTHON}"
+}