summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/irctokens/irctokens-2.0.2.ebuild')
-rw-r--r--dev-python/irctokens/irctokens-2.0.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/irctokens/irctokens-2.0.2.ebuild b/dev-python/irctokens/irctokens-2.0.2.ebuild
new file mode 100644
index 000000000000..ddf4c05d60c2
--- /dev/null
+++ b/dev-python/irctokens/irctokens-2.0.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="RFC1459 and IRCv3 protocol tokeniser library"
+HOMEPAGE="
+ https://github.com/jesopo/irctokens
+ https://pypi.org/project/irctokens/
+"
+# sdist is broken (missing VERSION)
+SRC_URI="
+ https://github.com/jesopo/irctokens/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0.2-exclude-tests.patch
+)
+
+BDEPEND="
+ test? (
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest