summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jaraco-envs/jaraco-envs-2.3.0.ebuild')
-rw-r--r--dev-python/jaraco-envs/jaraco-envs-2.3.0.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-python/jaraco-envs/jaraco-envs-2.3.0.ebuild b/dev-python/jaraco-envs/jaraco-envs-2.3.0.ebuild
deleted file mode 100644
index 03d3f5c600c0..000000000000
--- a/dev-python/jaraco-envs/jaraco-envs-2.3.0.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-
-inherit distutils-r1
-
-MY_P=${P/-/.}
-DESCRIPTION="Classes for orchestrating Python (virtual) environments"
-HOMEPAGE="https://github.com/jaraco/jaraco.envs"
-SRC_URI="mirror://pypi/${MY_P::1}/${PN/-/.}/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-RDEPEND="
- dev-python/path-py[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
-"
-
-# there are no actual tests, just flake8 etc
-RESTRICT="test"
-
-src_prepare() {
- # optional runtime dep, not used by anything in ::gentoo
- sed -i -e '/tox/d' setup.cfg || die
- distutils-r1_src_prepare
-}