summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jeepney/jeepney-0.8.0.ebuild')
-rw-r--r--dev-python/jeepney/jeepney-0.8.0.ebuild23
1 files changed, 10 insertions, 13 deletions
diff --git a/dev-python/jeepney/jeepney-0.8.0.ebuild b/dev-python/jeepney/jeepney-0.8.0.ebuild
index 36a4c43e75e3..0535bb47b0a8 100644
--- a/dev-python/jeepney/jeepney-0.8.0.ebuild
+++ b/dev-python/jeepney/jeepney-0.8.0.ebuild
@@ -1,16 +1,18 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( pypy3 python3_{8..11} )
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
-inherit distutils-r1
+inherit distutils-r1 pypi
DESCRIPTION="Low-level, pure Python DBus protocol wrapper"
-HOMEPAGE="https://gitlab.com/takluyver/jeepney/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="
+ https://gitlab.com/takluyver/jeepney/
+ https://pypi.org/project/jeepney/
+"
LICENSE="MIT"
SLOT="0"
@@ -19,21 +21,17 @@ IUSE="examples"
BDEPEND="
test? (
- dev-python/async_timeout[${PYTHON_USEDEP}]
+ dev-python/async-timeout[${PYTHON_USEDEP}]
>=dev-python/pytest-asyncio-0.7.1[${PYTHON_USEDEP}]
dev-python/testpath[${PYTHON_USEDEP}]
sys-apps/dbus
- $(python_gen_cond_dep '
- dev-python/pytest-trio[${PYTHON_USEDEP}]
- dev-python/trio[${PYTHON_USEDEP}]
- ' 'python3*')
)
"
distutils_enable_tests pytest
distutils_enable_sphinx docs \
- dev-python/sphinx_rtd_theme
+ dev-python/sphinx-rtd-theme
src_test() {
local dbus_params=(
@@ -48,8 +46,7 @@ src_test() {
python_test() {
local EPYTEST_IGNORE=()
- # keep in sync with python_gen_cond_dep!
- if [[ ${EPYTHON} != python3* ]]; then
+ if ! has_version "dev-python/pytest-trio[${PYTHON_USEDEP}]"; then
EPYTEST_IGNORE+=( jeepney/io/tests/test_trio.py )
fi
epytest