summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jsonpatch/jsonpatch-1.33.ebuild')
-rw-r--r--dev-python/jsonpatch/jsonpatch-1.33.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/dev-python/jsonpatch/jsonpatch-1.33.ebuild b/dev-python/jsonpatch/jsonpatch-1.33.ebuild
index 0dcdc83e1831..cdd23d1e88f9 100644
--- a/dev-python/jsonpatch/jsonpatch-1.33.ebuild
+++ b/dev-python/jsonpatch/jsonpatch-1.33.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1
@@ -35,6 +35,14 @@ BDEPEND="
)
"
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # https://github.com/stefankoegl/python-json-patch/pull/159
+ sed -e 's/unittest.makeSuite/unittest.defaultTestLoader.loadTestsFromTestCase/' \
+ -i ext_tests.py tests.py
+}
+
python_test() {
"${EPYTHON}" tests.py || die "Tests of tests.py fail with ${EPYTHON}"
"${EPYTHON}" ext_tests.py || die "Tests of ext_tests.py fail with ${EPYTHON}"