summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jsonrpclib/jsonrpclib-0_pre20150305.ebuild')
-rw-r--r--dev-python/jsonrpclib/jsonrpclib-0_pre20150305.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/jsonrpclib/jsonrpclib-0_pre20150305.ebuild b/dev-python/jsonrpclib/jsonrpclib-0_pre20150305.ebuild
new file mode 100644
index 000000000000..101ea1209ee4
--- /dev/null
+++ b/dev-python/jsonrpclib/jsonrpclib-0_pre20150305.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/joshmarshall/jsonrpclib.git"
+ inherit git-2
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~mips ~x86"
+fi
+
+DESCRIPTION="python implementation of the JSON-RPC spec (1.0 and 2.0)"
+HOMEPAGE="https://github.com/joshmarshall/jsonrpclib"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-python/simplejson"