summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jupyter/jupyter-1.0.0.ebuild')
-rw-r--r--dev-python/jupyter/jupyter-1.0.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/jupyter/jupyter-1.0.0.ebuild b/dev-python/jupyter/jupyter-1.0.0.ebuild
new file mode 100644
index 000000000000..7dfd0060b397
--- /dev/null
+++ b/dev-python/jupyter/jupyter-1.0.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter metapackage. Install all the Jupyter components in one go"
+HOMEPAGE="http://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+RDEPEND="
+ dev-python/notebook[${PYTHON_USEDEP}]
+ dev-python/qtconsole[${PYTHON_USEDEP}]
+ dev-python/jupyter_console[${PYTHON_USEDEP}]
+ dev-python/nbconvert[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/ipywidgets[${PYTHON_USEDEP}]"
+DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ if use doc; then
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( "${S}"/docs/build/html/. )
+ distutils-r1_python_install_all
+}