summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jupyterlab-lsp/jupyterlab-lsp-5.1.0.ebuild')
-rw-r--r--dev-python/jupyterlab-lsp/jupyterlab-lsp-5.1.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/jupyterlab-lsp/jupyterlab-lsp-5.1.0.ebuild b/dev-python/jupyterlab-lsp/jupyterlab-lsp-5.1.0.ebuild
new file mode 100644
index 000000000000..3f5f03ffb226
--- /dev/null
+++ b/dev-python/jupyterlab-lsp/jupyterlab-lsp-5.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Coding assistance for JupyterLab with Language Server Protocol"
+HOMEPAGE="
+ https://github.com/jupyter-lsp/jupyterlab-lsp/
+ https://pypi.org/project/jupyterlab-lsp/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/jupyterlab-4.1.0[${PYTHON_USEDEP}]
+ <dev-python/jupyterlab-5.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-lsp-2.0.0[${PYTHON_USEDEP}]
+"