summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/keyring/keyring-8.4.ebuild')
-rw-r--r--dev-python/keyring/keyring-8.4.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/dev-python/keyring/keyring-8.4.ebuild b/dev-python/keyring/keyring-8.4.ebuild
deleted file mode 100644
index 1d64631917db..000000000000
--- a/dev-python/keyring/keyring-8.4.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Provides access to the system keyring service"
-HOMEPAGE="https://github.com/jaraco/keyring"
-SRC_URI="mirror://pypi/k/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="PSF-2"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest-runner[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/gdata[$(python_gen_usedep 'python2*')]
- dev-python/keyczar[$(python_gen_usedep 'python2*')]
- dev-python/pycrypto[$(python_gen_usedep 'python*')]
- )"
-RDEPEND=""
-
-python_test() {
- py.test -v -v || die "testsuite failed under ${EPYTHON}"
-}