summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/lazy-object-proxy/lazy-object-proxy-1.7.1-r1.ebuild')
-rw-r--r--dev-python/lazy-object-proxy/lazy-object-proxy-1.7.1-r1.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/dev-python/lazy-object-proxy/lazy-object-proxy-1.7.1-r1.ebuild b/dev-python/lazy-object-proxy/lazy-object-proxy-1.7.1-r1.ebuild
deleted file mode 100644
index 04f81a6d98b8..000000000000
--- a/dev-python/lazy-object-proxy/lazy-object-proxy-1.7.1-r1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="A fast and thorough lazy object proxy"
-HOMEPAGE="
- https://github.com/ionelmc/python-lazy-object-proxy
- https://pypi.org/project/lazy-object-proxy/
- https://python-lazy-object-proxy.readthedocs.org/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
-
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # No need to benchmark
- sed \
- -e '/benchmark/s:test_:_&:g' \
- -e '/pytest.mark.benchmark/d' \
- -i tests/test_lazy_object_proxy.py || die
- distutils-r1_python_prepare_all
-}