summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/lesscpy/lesscpy-0.9j.ebuild')
-rw-r--r--dev-python/lesscpy/lesscpy-0.9j.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/lesscpy/lesscpy-0.9j.ebuild b/dev-python/lesscpy/lesscpy-0.9j.ebuild
new file mode 100644
index 000000000000..5ed205722884
--- /dev/null
+++ b/dev-python/lesscpy/lesscpy-0.9j.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A compiler written in Python for the LESS language"
+HOMEPAGE="https://pypi.python.org/pypi/lesscpy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/ply[${PYTHON_USEDEP}]"
+
+python_test() {
+ ${PYTHON} lesscpy/test/__main__.py || die "test failed under ${EPYTHON}"
+}