summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/livereload')
-rw-r--r--dev-python/livereload/Manifest2
-rw-r--r--dev-python/livereload/files/fix-tests.patch77
-rw-r--r--dev-python/livereload/livereload-2.3.2.ebuild42
-rw-r--r--dev-python/livereload/livereload-2.4.0.ebuild39
-rw-r--r--dev-python/livereload/metadata.xml13
5 files changed, 173 insertions, 0 deletions
diff --git a/dev-python/livereload/Manifest b/dev-python/livereload/Manifest
new file mode 100644
index 000000000000..5efc59e56cbb
--- /dev/null
+++ b/dev-python/livereload/Manifest
@@ -0,0 +1,2 @@
+DIST livereload-2.3.2.tar.gz 24119 SHA256 fa2959005a134d767409c129cbf94528a0eb5022c915da9c685e14f1adb81b63 SHA512 59dc5be184d80a8b3aa6f98a6bc12f98f2efe00a0497deadfe5275222be2e0865e182cf0d83fc7a6e5f7297a7bf26a30c3ad9af5eeb2517af8b7ab3946e4bb1d WHIRLPOOL acf0c4ffa017a65d67423bb28b36cfd4e8acec59c47cc845f98669a3368920fa1e4e33b4c86e00082aeb416225066091305adcf1e8919071825a192ab5127180
+DIST livereload-2.4.0.tar.gz 25258 SHA256 a3f162357d886710a317f6f8c0595ac1db176bd9db171f0ca751c4954c29b5e2 SHA512 9b961ed41224359e986873973840fae43387af1b773328ab1262d095879aeff98090d736d696abdfcd9b2f1c127a061a29d044df7cfa15ba218b0162576093a3 WHIRLPOOL 268d274d57b1e7f7587fd690dac2bae7051dde2d1b110a8953a84eea6e08017488d4ee0e59fbc1bb0a9468d7925913ca8cb28a74c13c291fd7e004a5322160cf
diff --git a/dev-python/livereload/files/fix-tests.patch b/dev-python/livereload/files/fix-tests.patch
new file mode 100644
index 000000000000..2c9208ad17aa
--- /dev/null
+++ b/dev-python/livereload/files/fix-tests.patch
@@ -0,0 +1,77 @@
+diff --git a/tests/test_watcher.py b/tests/test_watcher.py
+index fa0ae41..5310bdc 100644
+--- a/tests/test_watcher.py
++++ b/tests/test_watcher.py
+@@ -3,18 +3,22 @@
+ import os
+ import time
+ import shutil
++import unittest
+ from livereload.watcher import Watcher
+
+ tmpdir = os.path.join(os.path.dirname(__file__), 'tmp')
+
+
+-class TestWatcher(object):
++class TestWatcher(unittest.TestCase):
+
+ def setUp(self):
+ if os.path.isdir(tmpdir):
+ shutil.rmtree(tmpdir)
+ os.mkdir(tmpdir)
+
++ def tearDown(self):
++ shutil.rmtree(tmpdir)
++
+ def test_watch_dir(self):
+ os.mkdir(os.path.join(tmpdir, '.git'))
+ os.mkdir(os.path.join(tmpdir, '.hg'))
+@@ -25,6 +29,9 @@ class TestWatcher(object):
+ watcher.watch(tmpdir)
+ assert watcher.is_changed(tmpdir) is False
+
++ # sleep 1 second so that mtime will be different
++ time.sleep(1)
++
+ with open(os.path.join(tmpdir, 'foo'), 'w') as f:
+ f.write('')
+
+@@ -35,6 +42,9 @@ class TestWatcher(object):
+ watcher = Watcher()
+ watcher.count = 0
+
++ # sleep 1 second so that mtime will be different
++ time.sleep(1)
++
+ filepath = os.path.join(tmpdir, 'foo')
+ with open(filepath, 'w') as f:
+ f.write('')
+@@ -51,22 +61,24 @@ class TestWatcher(object):
+ with open(filepath, 'w') as f:
+ f.write('')
+
+- assert watcher.examine() == os.path.abspath(filepath)
++ rv = watcher.examine()
++ assert rv[0] == os.path.abspath(filepath)
+ assert watcher.count == 1
+
+ def test_watch_glob(self):
+ watcher = Watcher()
+ watcher.watch(tmpdir + '/*')
+- assert watcher.examine() is None
++ assert watcher.examine() == (None, None)
+
+ with open(os.path.join(tmpdir, 'foo.pyc'), 'w') as f:
+ f.write('')
+
+- assert watcher.examine() is None
++ assert watcher.examine() == (None, None)
+
+ filepath = os.path.join(tmpdir, 'foo')
+
+ with open(filepath, 'w') as f:
+ f.write('')
+
+- assert watcher.examine() == os.path.abspath(filepath)
++ rv = watcher.examine()
++ assert rv[0] == os.path.abspath(filepath)
diff --git a/dev-python/livereload/livereload-2.3.2.ebuild b/dev-python/livereload/livereload-2.3.2.ebuild
new file mode 100644
index 000000000000..84e37d988a58
--- /dev/null
+++ b/dev-python/livereload/livereload-2.3.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Python LiveReload is an awesome tool for web developers"
+HOMEPAGE="https://github.com/lepture/python-livereload"
+SRC_URI="https://github.com/lepture/python-${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE="examples test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+RDEPEND="www-servers/tornado[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ local PATCHES=(
+ "${FILESDIR}"/fix-tests.patch
+ )
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( example/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/livereload/livereload-2.4.0.ebuild b/dev-python/livereload/livereload-2.4.0.ebuild
new file mode 100644
index 000000000000..0290484c93fc
--- /dev/null
+++ b/dev-python/livereload/livereload-2.4.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Python LiveReload is an awesome tool for web developers"
+HOMEPAGE="https://github.com/lepture/python-livereload"
+SRC_URI="https://github.com/lepture/python-${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples test"
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="
+ ${CDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+RDEPEND="
+ ${CDEPEND}
+ dev-python/six[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ nosetests || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( example/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/livereload/metadata.xml b/dev-python/livereload/metadata.xml
new file mode 100644
index 000000000000..a7af8704e22c
--- /dev/null
+++ b/dev-python/livereload/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>alunduil@gentoo.org</email>
+ <name>Alex Brandt</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+ <upstream>
+ <remote-id type="github">lepture/python-livereload</remote-id>
+ </upstream>
+</pkgmetadata>