summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/natsort/natsort-4.0.3.ebuild')
-rw-r--r--dev-python/natsort/natsort-4.0.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/natsort/natsort-4.0.3.ebuild b/dev-python/natsort/natsort-4.0.3.ebuild
new file mode 100644
index 000000000000..314bd98dd4d1
--- /dev/null
+++ b/dev-python/natsort/natsort-4.0.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Natural sorting for Python"
+HOMEPAGE="https://pypi.python.org/pypi/natsort"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy)
+ )"
+
+python_test() {
+ py.test || die "Tests failed under ${EPYTHON}"
+}