summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/nuitka/nuitka-0.6.4.ebuild')
-rw-r--r--dev-python/nuitka/nuitka-0.6.4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/nuitka/nuitka-0.6.4.ebuild b/dev-python/nuitka/nuitka-0.6.4.ebuild
new file mode 100644
index 000000000000..b7b8079ee4b1
--- /dev/null
+++ b/dev-python/nuitka/nuitka-0.6.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_5 python3_6 python3_7)
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="https://www.nuitka.net"
+SRC_URI="https://nuitka.net/releases/${P^}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RDEPEND="${DEPEND}
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-util/scons[${PYTHON_USEDEP}]
+ "
+
+S="${WORKDIR}/${P^}"
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}