summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/numpydoc/numpydoc-1.2.1-r1.ebuild')
-rw-r--r--dev-python/numpydoc/numpydoc-1.2.1-r1.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-python/numpydoc/numpydoc-1.2.1-r1.ebuild b/dev-python/numpydoc/numpydoc-1.2.1-r1.ebuild
deleted file mode 100644
index 8a0d7f8dfe4d..000000000000
--- a/dev-python/numpydoc/numpydoc-1.2.1-r1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Sphinx extension to support docstrings in Numpy format"
-HOMEPAGE="https://pypi.org/project/numpydoc/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
-
-RDEPEND="
- >=dev-python/jinja-2.10[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.8[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- >=dev-python/matplotlib-3.2.1[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- sed -i -e 's:--cov-report= --cov=numpydoc::' setup.cfg || die
- # unpin the dep
- sed -i -e '/Jinja2/s:,<3.1::' setup.py || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # these require Internet (intersphinx)
- numpydoc/tests/test_full.py::test_MyClass
- numpydoc/tests/test_full.py::test_my_function
- )
- epytest --pyargs numpydoc
-}