summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/oslo-rootwrap/oslo-rootwrap-2.4.0.ebuild')
-rw-r--r--dev-python/oslo-rootwrap/oslo-rootwrap-2.4.0.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-python/oslo-rootwrap/oslo-rootwrap-2.4.0.ebuild b/dev-python/oslo-rootwrap/oslo-rootwrap-2.4.0.ebuild
deleted file mode 100644
index 4272b5884a91..000000000000
--- a/dev-python/oslo-rootwrap/oslo-rootwrap-2.4.0.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 python3_4 )
-
-inherit distutils-r1
-
-DESCRIPTION="The Oslo Rootwrap allows fine filtering of shell commands to run as root from OpenStack services"
-HOMEPAGE="https://pypi.python.org/pypi/oslo.config"
-SRC_URI="mirror://pypi/${PN:0:1}/oslo.rootwrap/oslo.rootwrap-${PV}.tar.gz"
-S="${WORKDIR}/oslo.rootwrap-${PV}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="test"
-
-CDEPEND="
- >=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
- test? (
- >=dev-python/fixtures-1.3.1[${PYTHON_USEDEP}]
- >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
- >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
- >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
- >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
- !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
- <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
- >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
- >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/mock-1.2[${PYTHON_USEDEP}]
- >=dev-python/eventlet-0.17.4[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}] )"
-RDEPEND=">=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
- sed -i '/^hacking/d' test-requirements.txt || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- sed -i 's/sbin\/ip/bin\/ip/g' tests/test_rootwrap.py
- nosetests tests/ || die "test failed under ${EPYTHON}"
-}