summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/patiencediff/patiencediff-0.2.15.ebuild')
-rw-r--r--dev-python/patiencediff/patiencediff-0.2.15.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/patiencediff/patiencediff-0.2.15.ebuild b/dev-python/patiencediff/patiencediff-0.2.15.ebuild
new file mode 100644
index 000000000000..fcd012081ca3
--- /dev/null
+++ b/dev-python/patiencediff/patiencediff-0.2.15.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python implementation of the patiencediff algorithm"
+HOMEPAGE="
+ https://github.com/breezy-team/patiencediff/
+ https://pypi.org/project/patiencediff/
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+distutils_enable_tests unittest
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ eunittest
+}