summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pefile/pefile-9999.ebuild')
-rw-r--r--dev-python/pefile/pefile-9999.ebuild11
1 files changed, 4 insertions, 7 deletions
diff --git a/dev-python/pefile/pefile-9999.ebuild b/dev-python/pefile/pefile-9999.ebuild
index e80b72dea457..7f530f4c4bec 100644
--- a/dev-python/pefile/pefile-9999.ebuild
+++ b/dev-python/pefile/pefile-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
DESCRIPTION="Module to read and work with Portable Executable (PE) files"
@@ -14,16 +14,13 @@ if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://github.com/erocarrera/pefile.git"
inherit git-r3
else
- SRC_URI="https://github.com/erocarrera/pefile/releases/download/v${PV}/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/erocarrera/pefile/releases/download/v${PV}/${P}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="amd64 ~arm ~arm64 ~loong ~riscv x86"
fi
LICENSE="MIT"
SLOT="0"
-RDEPEND="${PYTHON_DEPS}
- dev-python/future[${PYTHON_USEDEP}]"
-
# Unfortunately there is nothing we can test here. Upstream doesn't ship a test
# suite inside the release files. The test fixtures in the source repo is
# encrypted so that only their CI pipeline is able to run the tests.