summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pony/pony-0.7.13.ebuild')
-rw-r--r--dev-python/pony/pony-0.7.13.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pony/pony-0.7.13.ebuild b/dev-python/pony/pony-0.7.13.ebuild
new file mode 100644
index 000000000000..f5db45c4fdd2
--- /dev/null
+++ b/dev-python/pony/pony-0.7.13.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..8} )
+inherit distutils-r1
+
+DESCRIPTION="Python ORM with beautiful query syntax"
+HOMEPAGE="
+ https://ponyorm.org/
+ https://github.com/ponyorm/pony/"
+SRC_URI="
+ https://github.com/ponyorm/pony/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? ( $(python_gen_impl_dep sqlite) )"
+
+distutils_enable_tests unittest