summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/progress/progress-1.3.ebuild')
-rw-r--r--dev-python/progress/progress-1.3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/progress/progress-1.3.ebuild b/dev-python/progress/progress-1.3.ebuild
new file mode 100644
index 000000000000..c391e80d3d6c
--- /dev/null
+++ b/dev-python/progress/progress-1.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Easy to use progress bars"
+HOMEPAGE="https://pypi.python.org/pypi/progress https://github.com/verigak/progress/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="ISC"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# Not bundled
+RESTRICT="test"
+
+python_test() {
+ "${PYTHON}" test_progress.py || die
+}