summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyamg/pyamg-4.0.0.ebuild')
-rw-r--r--dev-python/pyamg/pyamg-4.0.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/pyamg/pyamg-4.0.0.ebuild b/dev-python/pyamg/pyamg-4.0.0.ebuild
new file mode 100644
index 000000000000..798cc36c9ec3
--- /dev/null
+++ b/dev-python/pyamg/pyamg-4.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=bdepend
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="Algebraic multigrid solvers in Python"
+HOMEPAGE="https://pyamg.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pybind11[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]"
+
+distutils_enable_tests setup.py
+
+PATCHES=( "${FILESDIR}"/${P}-test.patch )