summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pycxx/pycxx-7.1.8.ebuild')
-rw-r--r--dev-python/pycxx/pycxx-7.1.8.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/dev-python/pycxx/pycxx-7.1.8.ebuild b/dev-python/pycxx/pycxx-7.1.8.ebuild
index cadfdbb9e765..c55a7897a81e 100644
--- a/dev-python/pycxx/pycxx-7.1.8.ebuild
+++ b/dev-python/pycxx/pycxx-7.1.8.ebuild
@@ -3,21 +3,27 @@
EAPI="8"
-PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_COMPAT=( python3_{10..12} )
# DISTUTILS_USE_PEP517=setuptools broken, installs files to /usr/CXX
DISTUTILS_USE_SETUPTOOLS=no
inherit distutils-r1
DESCRIPTION="Set of facilities to extend Python with C++"
-HOMEPAGE="http://cxx.sourceforge.net"
-SRC_URI="mirror://sourceforge/cxx/${P}.tar.gz"
+HOMEPAGE="https://cxx.sourceforge.net"
+SRC_URI="https://downloads.sourceforge.net/cxx/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
IUSE="doc examples"
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ' 3.12)
+"
+
python_prepare_all() {
# Without this, pysvn fails.
# Src/Python3/cxxextensions.c: No such file or directory