summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pydiffx/pydiffx-1.0.1-r1.ebuild')
-rw-r--r--dev-python/pydiffx/pydiffx-1.0.1-r1.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/pydiffx/pydiffx-1.0.1-r1.ebuild b/dev-python/pydiffx/pydiffx-1.0.1-r1.ebuild
deleted file mode 100644
index d20ee3c8b60d..000000000000
--- a/dev-python/pydiffx/pydiffx-1.0.1-r1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-MY_P=diffx-pydiffx-release-${PV}
-DESCRIPTION="Python module for reading and writing DiffX files"
-HOMEPAGE="
- https://diffx.org/pydiffx/
- https://github.com/beanbaginc/diffx/
- https://pypi.org/project/pydiffx/
-"
-SRC_URI="
- https://github.com/beanbaginc/diffx/archive/pydiffx/release-${PV}.tar.gz
- -> ${MY_P}.tar.gz
-"
-S=${WORKDIR}/${MY_P}/python
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/kgb[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests unittest
-
-src_prepare() {
- # remove .dev tag that breaks revdeps
- sed -i -e '/tag_build/d' setup.cfg || die
- distutils-r1_src_prepare
-}