summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pylatexenc')
-rw-r--r--dev-python/pylatexenc/Manifest1
-rw-r--r--dev-python/pylatexenc/metadata.xml26
-rw-r--r--dev-python/pylatexenc/pylatexenc-2.10.ebuild25
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/pylatexenc/Manifest b/dev-python/pylatexenc/Manifest
new file mode 100644
index 000000000000..ebd6284223fd
--- /dev/null
+++ b/dev-python/pylatexenc/Manifest
@@ -0,0 +1 @@
+DIST pylatexenc-2.10.gh.tar.gz 721836 BLAKE2B 8512e052271c127809105280360706217f5134b2349d4b21dcec720addb4cff4157173f8350115de4142aea491da2efb1a2854b4310c48ec98061470be21654e SHA512 9728731e0c84324685b77ce17fae0bea445815e2c54394d2722c4412bbd914da49280ef36b5f3a0a0346e5d2129ca2d8d3b3b92356de3c6af9eed4247cf8bd43
diff --git a/dev-python/pylatexenc/metadata.xml b/dev-python/pylatexenc/metadata.xml
new file mode 100644
index 000000000000..fed9292985c7
--- /dev/null
+++ b/dev-python/pylatexenc/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- comaintainers-welcomed -->
+ <maintainer type="person" proxied="yes">
+ <email>gaboroszkar@protonmail.com</email>
+ <name>Gábor Oszkár Dénes</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ Simple LaTeX parser providing latex-to-unicode and unicode-to-latex conversion.
+ The pylatexenc.latexencode module provides a function unicode_to_latex() which converts a unicode string into LaTeX text and escape sequences. It should recognize accented characters and most math symbols. A couple of switches allow you to alter how this function behaves.
+ You can also run latexencode in command-line to convert plain unicode text (from the standard input or from files given on the command line) into LaTeX code, written on to the standard output.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">phfaist/pylatexenc</remote-id>
+ <remote-id type="pypi">pylatexenc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pylatexenc/pylatexenc-2.10.ebuild b/dev-python/pylatexenc/pylatexenc-2.10.ebuild
new file mode 100644
index 000000000000..fc5252a2998b
--- /dev/null
+++ b/dev-python/pylatexenc/pylatexenc-2.10.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple LaTeX parser providing latex-to-unicode and unicode-to-latex conversion"
+HOMEPAGE="
+ https://github.com/phfaist/pylatexenc/
+ https://pypi.org/project/pylatexenc/
+"
+SRC_URI="
+ https://github.com/phfaist/pylatexenc/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest