summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pypcap/pypcap-1.2.2.ebuild')
-rw-r--r--dev-python/pypcap/pypcap-1.2.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pypcap/pypcap-1.2.2.ebuild b/dev-python/pypcap/pypcap-1.2.2.ebuild
new file mode 100644
index 000000000000..f0425cdf8a9e
--- /dev/null
+++ b/dev-python/pypcap/pypcap-1.2.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+inherit distutils-r1
+
+DESCRIPTION="Simplified object-oriented Python extension module for libpcap"
+HOMEPAGE="https://github.com/pynetwork/pypcap https://pypi.org/project/pypcap/"
+SRC_URI="https://github.com/pynetwork/pypcap/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+
+RDEPEND="
+ net-libs/libpcap
+"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.6-mktemp.patch
+)
+
+python_compile() {
+ local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}