summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pypiserver/pypiserver-1.3.1.ebuild')
-rw-r--r--dev-python/pypiserver/pypiserver-1.3.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pypiserver/pypiserver-1.3.1.ebuild b/dev-python/pypiserver/pypiserver-1.3.1.ebuild
new file mode 100644
index 000000000000..29f0c61101a1
--- /dev/null
+++ b/dev-python/pypiserver/pypiserver-1.3.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Minimal PyPI server"
+HOMEPAGE="https://github.com/pypiserver/pypiserver"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/wheel-0.25.0[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+ dev-python/setuptools-git[${PYTHON_USEDEP}]
+ test? (
+ dev-python/passlib[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.3[${PYTHON_USEDEP}]
+ dev-python/tox[${PYTHON_USEDEP}]
+ dev-python/twine[${PYTHON_USEDEP}]
+ dev-python/webtest[${PYTHON_USEDEP}]
+ )"
+
+# tests need access to pypi.org
+#RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/pypiserver-1.3.1-no-internet.patch"
+)
+
+DOCS=( README.rst )
+
+distutils_enable_tests pytest