summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyprof2calltree')
-rw-r--r--dev-python/pyprof2calltree/Manifest2
-rw-r--r--dev-python/pyprof2calltree/pyprof2calltree-1.4.5-r1.ebuild26
-rw-r--r--dev-python/pyprof2calltree/pyprof2calltree-1.4.5.ebuild18
3 files changed, 27 insertions, 19 deletions
diff --git a/dev-python/pyprof2calltree/Manifest b/dev-python/pyprof2calltree/Manifest
index cbeea65c4c4e..d948d8d42544 100644
--- a/dev-python/pyprof2calltree/Manifest
+++ b/dev-python/pyprof2calltree/Manifest
@@ -1 +1 @@
-DIST pyprof2calltree-1.4.5.tar.gz 8806 BLAKE2B 3a8a838a8b03294504c64dbe1d0caee2606a1ec53005222dfe6c3692bacd0801041ce199fedb9c38e4f6edc91e210116d9c1e034e0aa283cafebb19bf6303fed SHA512 2fcda74ae67dc3a8abb5dc153864ef59f96cc62b1c9359d02be12e83966c17738f5aa4a3d1c6e2ff81614dc963fc4b2faf375bbbb1ad15650a6817e493cdde39
+DIST pyprof2calltree-1.4.5.gh.tar.gz 8806 BLAKE2B 3a8a838a8b03294504c64dbe1d0caee2606a1ec53005222dfe6c3692bacd0801041ce199fedb9c38e4f6edc91e210116d9c1e034e0aa283cafebb19bf6303fed SHA512 2fcda74ae67dc3a8abb5dc153864ef59f96cc62b1c9359d02be12e83966c17738f5aa4a3d1c6e2ff81614dc963fc4b2faf375bbbb1ad15650a6817e493cdde39
diff --git a/dev-python/pyprof2calltree/pyprof2calltree-1.4.5-r1.ebuild b/dev-python/pyprof2calltree/pyprof2calltree-1.4.5-r1.ebuild
new file mode 100644
index 000000000000..3778cd3e6a0e
--- /dev/null
+++ b/dev-python/pyprof2calltree/pyprof2calltree-1.4.5-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="convert python profile data to kcachegrind calltree form"
+HOMEPAGE="
+ https://github.com/pwaller/pyprof2calltree/
+ https://pypi.org/project/pyprof2calltree/
+"
+# pypi tarball lacks tests
+SRC_URI="
+ https://github.com/pwaller/pyprof2calltree/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+distutils_enable_tests unittest
diff --git a/dev-python/pyprof2calltree/pyprof2calltree-1.4.5.ebuild b/dev-python/pyprof2calltree/pyprof2calltree-1.4.5.ebuild
deleted file mode 100644
index a979232643d7..000000000000
--- a/dev-python/pyprof2calltree/pyprof2calltree-1.4.5.ebuild
+++ /dev/null
@@ -1,18 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} )
-inherit distutils-r1
-
-DESCRIPTION="convert python profile data to kcachegrind calltree form"
-HOMEPAGE="https://pypi.org/project/pyprof2calltree/"
-# pypi tarball lacks tests
-SRC_URI="https://github.com/pwaller/pyprof2calltree/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-distutils_enable_tests setup.py