summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyroute2/pyroute2-0.5.5-r1.ebuild')
-rw-r--r--dev-python/pyroute2/pyroute2-0.5.5-r1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/pyroute2/pyroute2-0.5.5-r1.ebuild b/dev-python/pyroute2/pyroute2-0.5.5-r1.ebuild
new file mode 100644
index 000000000000..c144bf26f0c9
--- /dev/null
+++ b/dev-python/pyroute2/pyroute2-0.5.5-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="A pure Python netlink and Linux network configuration library."
+HOMEPAGE="https://github.com/svinota/pyroute2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""