summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-services/pytest-services-2.2.1.ebuild')
-rw-r--r--dev-python/pytest-services/pytest-services-2.2.1.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-python/pytest-services/pytest-services-2.2.1.ebuild b/dev-python/pytest-services/pytest-services-2.2.1.ebuild
deleted file mode 100644
index 67efd3025477..000000000000
--- a/dev-python/pytest-services/pytest-services-2.2.1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="Collection of fixtures and utility functions to run service processes for pytest"
-HOMEPAGE="https://github.com/pytest-dev/pytest-services"
-SRC_URI="https://github.com/pytest-dev/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~ia64 ppc ~ppc64 ~riscv x86"
-IUSE="test"
-
-RDEPEND="
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/zc-lockfile[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? ( ${RDEPEND}
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pylibmc[${PYTHON_USEDEP}]
- x11-base/xorg-server[xvfb]
- net-misc/memcached
- !dev-python/pytest-salt
- )
-"
-
-RESTRICT="!test? ( test )"
-
-PATCHES=(
- "${FILESDIR}/pytest-services-2.0.1-no-mysql.patch"
- "${FILESDIR}/pytest-services-2.0.1-lockdir.patch"
-)
-
-python_test() {
- distutils_install_for_testing
- pytest -vv tests || die "Tests failed under ${EPYTHON}"
-}
-
-python_install() {
- distutils-r1_python_install
-
- find "${D}" -name '*.pth' -delete || die
-}