summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-timeout/pytest-timeout-2.0.2.ebuild')
-rw-r--r--dev-python/pytest-timeout/pytest-timeout-2.0.2.ebuild27
1 files changed, 0 insertions, 27 deletions
diff --git a/dev-python/pytest-timeout/pytest-timeout-2.0.2.ebuild b/dev-python/pytest-timeout/pytest-timeout-2.0.2.ebuild
deleted file mode 100644
index f11adfbb8c3a..000000000000
--- a/dev-python/pytest-timeout/pytest-timeout-2.0.2.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="pytest plugin to abort hanging tests"
-HOMEPAGE="https://pypi.org/project/pytest-timeout/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-
-# do not rdepend on pytest, it won't be used without it anyway
-# pytest-cov used to test compatibility
-BDEPEND="
- test? (
- dev-python/pexpect[${PYTHON_USEDEP}]
- !hppa? (
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- )
- )"
-
-distutils_enable_tests --install pytest