summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-debian/python-debian-0.1.49.ebuild')
-rw-r--r--dev-python/python-debian/python-debian-0.1.49.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-python/python-debian/python-debian-0.1.49.ebuild b/dev-python/python-debian/python-debian-0.1.49.ebuild
index d99f43c8102f..855bcbe7bcc8 100644
--- a/dev-python/python-debian/python-debian-0.1.49.ebuild
+++ b/dev-python/python-debian/python-debian-0.1.49.ebuild
@@ -1,10 +1,10 @@
-# Copyright 2011-2023 Gentoo Authors
+# Copyright 2011-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1
@@ -32,10 +32,13 @@ BDEPEND="
distutils_enable_tests pytest
python_prepare_all() {
+ distutils-r1_python_prepare_all
+
# See debian/rules.
sed -e "s/__CHANGELOG_VERSION__/${PV}/" lib/debian/_version.py.in \
> lib/debian/_version.py || die
- distutils-r1_python_prepare_all
+ # silence false positives
+ rm -rf debian || die
}
python_compile_all() {