summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-discid/python-discid-1.1.1.ebuild')
-rw-r--r--dev-python/python-discid/python-discid-1.1.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/python-discid/python-discid-1.1.1.ebuild b/dev-python/python-discid/python-discid-1.1.1.ebuild
new file mode 100644
index 000000000000..3162cd2694eb
--- /dev/null
+++ b/dev-python/python-discid/python-discid-1.1.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for libdiscid"
+HOMEPAGE="https://github.com/JonnyJD/python-discid"
+SRC_URI="https://github.com/JonnyJD/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+RDEPEND=">=media-libs/libdiscid-0.2.2"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_compile_all() {
+ if use doc; then
+ cd doc || die
+ sphinx-build . _build/html || die
+ HTML_DOCS=( doc/_build/html/. )
+ fi
+}
+
+python_test() {
+ esetup.py test
+}