summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-iptables/python-iptables-1.0.0.ebuild')
-rw-r--r--dev-python/python-iptables/python-iptables-1.0.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/python-iptables/python-iptables-1.0.0.ebuild b/dev-python/python-iptables/python-iptables-1.0.0.ebuild
new file mode 100644
index 000000000000..53037c8775b5
--- /dev/null
+++ b/dev-python/python-iptables/python-iptables-1.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for iptables"
+HOMEPAGE="https://github.com/ldx/python-iptables"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="net-firewall/iptables"
+
+# tests manipulate live iptables rules, so disable them by default
+RESTRICT="test"
+
+distutils_enable_sphinx doc
+distutils_enable_tests setup.py
+
+python_prepare_all() {
+ # Prevent un-needed d'loading during doc build
+ sed -e "s/, 'sphinx.ext.intersphinx'//" -i doc/conf.py || die
+ distutils-r1_python_prepare_all
+}