summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-senlinclient/python-senlinclient-1.0.0.ebuild')
-rw-r--r--dev-python/python-senlinclient/python-senlinclient-1.0.0.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-python/python-senlinclient/python-senlinclient-1.0.0.ebuild b/dev-python/python-senlinclient/python-senlinclient-1.0.0.ebuild
deleted file mode 100644
index 254bef682c4f..000000000000
--- a/dev-python/python-senlinclient/python-senlinclient-1.0.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_5 )
-
-inherit distutils-r1
-
-DESCRIPTION="A client for the OpenStack Senlin API"
-HOMEPAGE="https://github.com/openstack/python-senlinclient"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
-
-CDEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}"
-RDEPEND="
- ${CDEPEND}
- >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
- >=dev-python/prettytable-0.7[${PYTHON_USEDEP}]
- <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
- >=dev-python/openstacksdk-0.9.4
- >=dev-python/osc-lib-1.0.2
- >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-utils-3.16.0[${PYTHON_USEDEP}]
- >=dev-python/python-heatclient-1.4.0
- >=dev-python/pyyaml-3.1.0
- >=dev-python/requests-2.10.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
-"
-
-python_prepare_all() {
- # built in...
- sed -i '/^hacking/d' test-requirements.txt || die
- distutils-r1_python_prepare_all
-}