summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-termstyle/python-termstyle-0.1.10.ebuild')
-rw-r--r--dev-python/python-termstyle/python-termstyle-0.1.10.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/python-termstyle/python-termstyle-0.1.10.ebuild b/dev-python/python-termstyle/python-termstyle-0.1.10.ebuild
new file mode 100644
index 000000000000..a12818def643
--- /dev/null
+++ b/dev-python/python-termstyle/python-termstyle-0.1.10.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python{3_3,3_4} pypy )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="console colouring for python"
+HOMEPAGE="http://gfxmonk.net/dist/0install/python-termstyle.xml"
+SRC_URI="https://github.com/gfxmonk/${PN#*-}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+RDEPEND=""
+
+python_prepare_all() {
+ local PATCHES=(
+ "${FILESDIR}"/tests-unicode.patch
+ )
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ if [[ "${EPYTHON}" = "python2.7" ]]; then
+ "${PYTHON}" test2.py || die "test2.py failed under ${EPYTHON}"
+ else
+ "${PYTHON}" test3.py || die "test3.py failed under ${EPYTHON}"
+ fi
+}