summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/qrcode/qrcode-7.3.1-r1.ebuild')
-rw-r--r--dev-python/qrcode/qrcode-7.3.1-r1.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/qrcode/qrcode-7.3.1-r1.ebuild b/dev-python/qrcode/qrcode-7.3.1-r1.ebuild
deleted file mode 100644
index 4fa3210b32ad..000000000000
--- a/dev-python/qrcode/qrcode-7.3.1-r1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="QR Code generator on top of PIL"
-HOMEPAGE="
- https://github.com/lincolnloop/python-qrcode/
- https://pypi.org/project/qrcode/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
-
-# optional deps:
-# - pillow and lxml for svg backend, set as hard deps
-RDEPEND="
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # TODO
- qrcode/tests/test_script.py::ScriptTest::test_factory
-)
-
-src_install() {
- distutils-r1_src_install
- doman doc/qr.1
-}