summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/rarfile')
-rw-r--r--dev-python/rarfile/Manifest2
-rw-r--r--dev-python/rarfile/files/rarfile-4.0.patch22
-rw-r--r--dev-python/rarfile/rarfile-4.0-r1.ebuild24
-rw-r--r--dev-python/rarfile/rarfile-4.2.ebuild27
4 files changed, 28 insertions, 47 deletions
diff --git a/dev-python/rarfile/Manifest b/dev-python/rarfile/Manifest
index a37f413492e3..a583dacc249e 100644
--- a/dev-python/rarfile/Manifest
+++ b/dev-python/rarfile/Manifest
@@ -1 +1 @@
-DIST rarfile-4.0.tar.gz 148026 BLAKE2B 331548d54dcc3d81c690cc383e36e3f00515999c72abb54060e0dbb34691bb7e06736318a33ec349492e27e561ed2f4ff4446cc5254e9f341f4633adaab878aa SHA512 05e15acd749564288d4f069970ac196344c33fd2710e918b84afe4c388aa364a17c63f86577037524336e3a022f6db2c8619f9b526f89e00753a8ab0d89263d4
+DIST rarfile-4.2.tar.gz 153476 BLAKE2B ddaf85bf0edeb7203a6d1007c118facd53dc5c310ed110f087ec990532f576d601075b4a2455657dc5730ed3668f6494e4fd3132efeb95a821162dbda91caf23 SHA512 fed3943a6d201d4832ee5377069ea400e58394590dd5022cdd7b6f6944c9bf1b6c26387aa0db4c56d5d82f6d10d0cecd2e438e224287cdbdb3314770848c14d8
diff --git a/dev-python/rarfile/files/rarfile-4.0.patch b/dev-python/rarfile/files/rarfile-4.0.patch
deleted file mode 100644
index e9d3251b6da2..000000000000
--- a/dev-python/rarfile/files/rarfile-4.0.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff -r -U2 rarfile-4.0.orig/test/test_tool.py rarfile-4.0/test/test_tool.py
---- rarfile-4.0.orig/test/test_tool.py 2020-08-01 01:25:50.000000000 +0700
-+++ rarfile-4.0/test/test_tool.py 2021-10-03 22:35:22.329537879 +0700
-@@ -33,5 +33,5 @@
-
-
--@pytest.mark.skipif(sys.platform == "win32", reason="unar not available on Windows")
-+@pytest.mark.skip()
- def test_unar_tool():
- install_unar_tool()
-@@ -43,4 +43,5 @@
-
-
-+@pytest.mark.skip()
- def test_bsdtar_tool():
- install_bsdtar_tool()
-@@ -114,4 +115,5 @@
-
-
-+@pytest.mark.skip()
- def test_cli_help(capsys):
- assert cli("--help") == 0
diff --git a/dev-python/rarfile/rarfile-4.0-r1.ebuild b/dev-python/rarfile/rarfile-4.0-r1.ebuild
deleted file mode 100644
index e7359028d806..000000000000
--- a/dev-python/rarfile/rarfile-4.0-r1.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTLS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="Module for RAR archive reading"
-HOMEPAGE="https://github.com/markokr/rarfile"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="ISC"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-IUSE="+compressed test"
-REQUIRED_USE="test? ( compressed )"
-
-RDEPEND="compressed? ( app-arch/unrar )"
-
-PATCHES=( "${FILESDIR}"/${P}.patch )
-
-distutils_enable_tests pytest
diff --git a/dev-python/rarfile/rarfile-4.2.ebuild b/dev-python/rarfile/rarfile-4.2.ebuild
new file mode 100644
index 000000000000..0b0a69392cf7
--- /dev/null
+++ b/dev-python/rarfile/rarfile-4.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Module for RAR archive reading"
+HOMEPAGE="
+ https://github.com/markokr/rarfile/
+ https://pypi.org/project/rarfile/
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 x86"
+IUSE="+compressed test"
+REQUIRED_USE="test? ( compressed )"
+
+RDEPEND="
+ compressed? ( app-arch/unrar )
+"
+
+distutils_enable_tests pytest