summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/rfc3986-validator/rfc3986-validator-0.1.1-r2.ebuild')
-rw-r--r--dev-python/rfc3986-validator/rfc3986-validator-0.1.1-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/rfc3986-validator/rfc3986-validator-0.1.1-r2.ebuild b/dev-python/rfc3986-validator/rfc3986-validator-0.1.1-r2.ebuild
new file mode 100644
index 000000000000..4754716592c5
--- /dev/null
+++ b/dev-python/rfc3986-validator/rfc3986-validator-0.1.1-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pure python RFC3986 validator"
+HOMEPAGE="
+ https://pypi.org/project/rfc3986-validator/
+ https://github.com/naimetti/rfc3986-validator
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~arm64-macos ~x64-macos"
+
+# not a typo, it actually test-depends on rfc3987, and not rfc3986
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/rfc3987[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # remove dep on pytest-runner
+ sed -i -r "s:('|\")pytest-runner('|\")(,|)::" setup.py || die
+ distutils-r1_python_prepare_all
+}