summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ropemode')
-rw-r--r--dev-python/ropemode/Manifest1
-rw-r--r--dev-python/ropemode/ropemode-0.5.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/ropemode/Manifest b/dev-python/ropemode/Manifest
index bf3628dc0ee9..ed4b6bdfc5c8 100644
--- a/dev-python/ropemode/Manifest
+++ b/dev-python/ropemode/Manifest
@@ -1 +1,2 @@
DIST ropemode-0.4.tar.gz 12846 BLAKE2B 1cf2f2fd9528e078dc47e429631a3ebc7e1de82bb474435c6fe0c640d2d5bc706ed8d3c665b77836f07d715af991cd1cd202af9675429f70b0f7d47f05757d9e SHA512 b8d592b42a6cdeb73b123b94d24bbb0eedc38414b60c931c9d1a7bf3c6fc4958d2db0431f57f281987c89d3b27dd2e45701d386274024a2a79bf8183547c8489
+DIST ropemode-0.5.tar.gz 15328 BLAKE2B 051c92a6105c0226c2a2daafbb55485327fcb8777467fc4ff86e1491f9fbbe39cec90100c212ebc64d08d6b1803638597eea0852222f29187b6fe92542a80b3c SHA512 50740982a731045734150171e0c3ae26ccf64bef4699fc7062204c68750b760a373d5b2b0e00b8ba8057d3955059ca1dce2a41cc1878775698184d78f921b76c
diff --git a/dev-python/ropemode/ropemode-0.5.ebuild b/dev-python/ropemode/ropemode-0.5.ebuild
new file mode 100644
index 000000000000..2c3fb327d4cc
--- /dev/null
+++ b/dev-python/ropemode/ropemode-0.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Currently (2020-03-23) rope is blocking
+# support for python 3.8.
+# For details see
+# https://github.com/python-rope/rope/pull/285
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A helper for using rope refactoring library in IDEs"
+HOMEPAGE="https://github.com/python-rope/ropemode https://pypi.org/project/ropemode/"
+SRC_URI="https://github.com/python-rope/ropemode/archive/${PV}.tar.gz -> ${P}.tar.gz"
+# pypi releases don't include tests
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/rope[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" ropemodetest.py || die "tests failed with ${EPYTHON}"
+}