summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/six/files/1.10.0-no-setuptools.patch')
-rw-r--r--dev-python/six/files/1.10.0-no-setuptools.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/six/files/1.10.0-no-setuptools.patch b/dev-python/six/files/1.10.0-no-setuptools.patch
new file mode 100644
index 000000000000..d4309181902a
--- /dev/null
+++ b/dev-python/six/files/1.10.0-no-setuptools.patch
@@ -0,0 +1,22 @@
+Force distutils to avoid depending on setuptools
+
+distutils and setuptools have differing behavior in regard to egg-info
+directories versus files, so we need to ensure that no automagic behavior
+occurs here.
+
+We cannot hard-depend on setuptools due to a circular dependency.
+
+diff --git a/setup.py b/setup.py
+--- a/setup.py
++++ b/setup.py
+@@ -1,9 +1,6 @@
+ from __future__ import with_statement
+
+-try:
+- from setuptools import setup
+-except ImportError:
+- from distutils.core import setup
++from distutils.core import setup
+
+ import six
+