summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/six/six-1.10.0.ebuild')
-rw-r--r--dev-python/six/six-1.10.0.ebuild19
1 files changed, 3 insertions, 16 deletions
diff --git a/dev-python/six/six-1.10.0.ebuild b/dev-python/six/six-1.10.0.ebuild
index 2774a6298ab2..b00b76cf9777 100644
--- a/dev-python/six/six-1.10.0.ebuild
+++ b/dev-python/six/six-1.10.0.ebuild
@@ -26,25 +26,12 @@ PATCHES=(
"${FILESDIR}"/1.9.0-mapping.patch
)
-# Run twice.
-# pkg_pretend to catch as early as possible, but be forgiving if
-# python impl is not installed allready.
-# pkg_setup to catch them all
-pkg_pretend() {
- six_dir_check() {
- type -p "${PYTHON}" > /dev/null || return 0
- local dir="${ROOT%/}$(python_get_sitedir)"/six
- [[ -d "${dir}" ]] \
- && die "${PN} doesn't work if ${dir} is a directory #546730"
- }
- python_foreach_impl six_dir_check
-}
-
pkg_setup() {
six_dir_check() {
local dir="${ROOT%/}$(python_get_sitedir)"/six
- [[ -d "${dir}" ]] \
- && die "${PN} doesn't work if ${dir} is a directory #546730"
+ if [[ -d "${dir}" ]]; then
+ die "${PN} doesn't work if ${dir} is a directory #546730"
+ fi
}
python_foreach_impl six_dir_check
}