summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/six/six-1.10.0.ebuild')
-rw-r--r--dev-python/six/six-1.10.0.ebuild10
1 files changed, 10 insertions, 0 deletions
diff --git a/dev-python/six/six-1.10.0.ebuild b/dev-python/six/six-1.10.0.ebuild
index 465102afe7fe..943c0f6c935f 100644
--- a/dev-python/six/six-1.10.0.ebuild
+++ b/dev-python/six/six-1.10.0.ebuild
@@ -26,6 +26,16 @@ PATCHES=(
"${FILESDIR}"/1.9.0-mapping.patch
)
+python_prepare_all() {
+ # https://bitbucket.org/gutworth/six/issues/139/
+ sed \
+ -e 's:test_assertCountEqual:_&:g' \
+ -e 's:test_assertRegex:_&:g' \
+ -e 's:test_assertRaisesRegex:_&:g' \
+ -i test_six.py || die
+ distutils-r1_python_prepare_all
+}
+
python_compile_all() {
use doc && emake -C documentation html
}