summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/six/six-1.6.1.ebuild')
-rw-r--r--dev-python/six/six-1.6.1.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-python/six/six-1.6.1.ebuild b/dev-python/six/six-1.6.1.ebuild
deleted file mode 100644
index 810fde907be7..000000000000
--- a/dev-python/six/six-1.6.1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Python 2 and 3 compatibility library"
-HOMEPAGE="https://bitbucket.org/gutworth/six https://pypi.python.org/pypi/six"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ~ppc ~ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="doc test"
-
-DEPEND="doc? ( dev-python/sphinx )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-PATCHES=( "${FILESDIR}"/${PN}-1.5.2-mapping.patch )
-
-python_compile_all() {
- use doc && emake -C documentation html
-}
-
-python_test() {
- py.test -v || die "Testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( documentation/_build/html/ )
- distutils-r1_python_install_all
-}