summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sortedcontainers/sortedcontainers-2.4.0.ebuild')
-rw-r--r--dev-python/sortedcontainers/sortedcontainers-2.4.0.ebuild28
1 files changed, 0 insertions, 28 deletions
diff --git a/dev-python/sortedcontainers/sortedcontainers-2.4.0.ebuild b/dev-python/sortedcontainers/sortedcontainers-2.4.0.ebuild
deleted file mode 100644
index 17aab8883a00..000000000000
--- a/dev-python/sortedcontainers/sortedcontainers-2.4.0.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
-
-inherit distutils-r1
-
-MY_P=python-${P}
-DESCRIPTION="Python library to sort collections and containers"
-HOMEPAGE="http://www.grantjenks.com/docs/sortedcontainers/
- https://pypi.org/project/sortedcontainers/
- https://github.com/grantjenks/python-sortedcontainers/"
-SRC_URI="
- https://github.com/grantjenks/python-sortedcontainers/archive/v${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-
-distutils_enable_tests pytest
-
-python_test() {
- local -x PYTHONPATH=.
- epytest --ignore docs/conf.py
-}