summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/texttable/texttable-1.2.1.ebuild')
-rw-r--r--dev-python/texttable/texttable-1.2.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/texttable/texttable-1.2.1.ebuild b/dev-python/texttable/texttable-1.2.1.ebuild
new file mode 100644
index 000000000000..33dddd685225
--- /dev/null
+++ b/dev-python/texttable/texttable-1.2.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Module for creating simple ASCII tables"
+HOMEPAGE="https://github.com/foutaise/texttable"
+SRC_URI="https://github.com/foutaise/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cjk test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ cjk? ( dev-python/cjkwrap[${PYTHON_USEDEP}] )
+ )
+"
+RDEPEND="
+ cjk? ( dev-python/cjkwrap[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ py.test -v tests.py || die
+}