summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/txaio/txaio-2.3.1.ebuild')
-rw-r--r--dev-python/txaio/txaio-2.3.1.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-python/txaio/txaio-2.3.1.ebuild b/dev-python/txaio/txaio-2.3.1.ebuild
deleted file mode 100644
index 053c2fc4dfb0..000000000000
--- a/dev-python/txaio/txaio-2.3.1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4} )
-
-RESTRICT="test"
-
-inherit distutils-r1
-
-DESCRIPTION="a helper library for writing code unmodified on both Twisted and asyncio"
-HOMEPAGE="https://github.com/crossbario/txaio"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="doc test"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]
- >=dev-python/pep8-1.6.2[${PYTHON_USEDEP}]"
-
-DEPEND="app-arch/unzip
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/alabaster[${PYTHON_USEDEP}] )
- test? ( >=dev-python/pytest-2.6.4[${PYTHON_USEDEP}]
- >=dev-python/pytest-cov-1.8.1[${PYTHON_USEDEP}] )"
-
-python_prepare() {
- # https://github.com/tavendo/txaio/issues/3
- cp -r "${FILESDIR}"/util.py test || die
-
- distutils-r1_python_prepare
-}
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_test() {
- py.test || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( doc/_build/html/. )
- distutils-r1_python_install_all
-}